XLS output related properties

ApplyI18forDataFields

This property defines if internationalization should be applied to this report.

  • True: To apply internationalization.
  • False: For not applying internationalization.

XLColumn

Set value for this property if this report will be exported to MS Excel format. Value set in this property decides the column in which selected control will be rendered.

The exact column will be calculated based on location of the control in the section and values set in XLCellHeight and XLCellWidth properties.

XLColumnSpan

Set value for this property if this report will be exported to MS Excel format. Value set in this property decides the number of cells to be kept blank before rendering the next control on its right.

For example, value in column A is long and may extend 5 columns, set this property to 5. This will ensure that value of the next field is placed in column F. If the data is smaller in width and does not expand all the columns, format is copied in all the columns.

XLRow

Set value for this property if this report will be exported to MS Excel format. The value set in this property will decide relative row number in which the control should be placed. It actually works like previous row count plus the value set here.

The exact row number will be calculated based on location of the control in the section and values set in XLCellHeight and XLCellWidth properties.

Note: To decide the actual row in which this control will be placed, Intellicus adds the value of XLRow in the row number in which control of the previous record was placed. For example, for a control placed in detail section, if last record was placed in row 5, XLRow = 1 will make sure next record is placed in row 6, that is, (5 + 1).

XLRowSpan

Set value for this property if this report will be exported to MS Excel format. It is used to define number of rows to be kept blank below the cell. Format is copied in all the columns. The exact count of row will be calculated based on location of the control in the section and value of XLCellHeight and XLCellWidth properties.

For example, after cell A1, to keep cells A2 and A3 empty, set XLRowSpan to 3. This will ensure that value of the next record is placed in row A4.

XLStartColumn

Value of this property defines starting column of cross-tab when exported to MS Excel.

XLStartRow

Value of this property defines starting row of cross-tab when exported to MS Excel.

XLCellHeight

This property is applicable when a report is going to be exported in MS Excel. When value for XLColumn and XLRow is not set, value set in this property decides height of cell.

XLCellWidth

This property is applicable when a report is going to be exported in MS Excel. When value for XLColumn and XLRow is not set, value set in this property decides width of cell.

XLBackground

This property is applicable when a report is going to be exported in MS Excel.

  • True: Background will be applied in MS Excel output.
  • False: Background will not be applied in MS Excel output.

See Also

  • Appearance
  • Behavior
  • CSV Output format
  • Data
  • Font
  • Image Rendering
  • Miscellaneous
  • Position
  • Text
  • XML Output


Miscellaneous properties

(Custom)

To select format for the values stored in selected control.

(Name)

Name of the report component that uniquely identifies it. The name is auto-generated, which can be replaced by a new one.

ClassName

This property will be available in the Properties list when you select a control from the layout pane. It defines the control’s global styles. The global styles are specified in the styles drop down box.

To perform the same using the Script Editor, type the following code:

Object: Detail
Event: OnFormat
Code:
function OnFormat()
{
rpt.sections("Details").controls("txtName").className = "heading2";
}

CaptionPos

This property will be there on the property pane when the page header is selected. Value of this property determines position of page header on report.

  • OnAllPHs: Page header will appear on all the pages of the report.
  • Below RH and On all PHs following RH: On the report page where report header is setup, the page header will appear below the report header.

CategoryName

Applicable for sub-report. This is a read-only property. Value is automatically displayed when report is selected in "Source" for a referenced sub-report.

DataField

This property is available for a field or a group header section. It defines the binding field and a group. This value is set to the name of any field in the data source, or the name of a custom field added into the field’s collection.

When the DataField property is set for the group, records in the detail section will be grouped by this field. When the DataField property is set for a field, Intellicus Studio binds the field's data from each record in the database to the selected control. The record set data is first saved into the data value, and then passed through any (defined) output format, to be set as the control's text.

When using XML the DataField must be set to a valid ‘Xpath’ string.

Important: The base path set by the ‘RecordSetPattern’ is used as the starting node; if a control needs to use a higher level node, use "../" to move back a node.

The DataField property can also be used to perform calculations using scripting expression by stating the property, proceeded by an ‘=’ symbol. This allows the fields to be set up to display the calculated results. Example; rpt.sections("ghClient").dataField= "CustomerID";

Warning: Intellicus Studio will NOT sort the data automatically. The SQL must have proper Order By statement in the same sequence in which the report has been grouped.

DateGroupBy

The way date type field should be grouped. Valid values are: DAY, WEEK, MONTH, QTR, YEAR.

DataSize

Size of the data field. This is a "read only" property.

DataType

Type of the data field. It can be NUMBER (for number), CHAR (for character), DATE (for date). Change the data field type as per need, for example "Start Date" may be a database field of CHAR type. Select DATE here to use it as DATE field.

DocumentName

Name for the report. This name is used by print spooler at the time of printing to identify this report.

NumericGroupBy

The property is available for a chart control. Specify a number indicating group. For example, to form group of 1-5, 6-10, specify 5 for this value.

OnPages

This property will appear on property pane when the Page Header or the Page Footer is selected. Set this property to control appearance of the Page header or Page footer section.

This property will be effective on the Page Header or Page Footer which ever is selected while setting value of this property.

  • All Pages: Selected section will appear on all the pages.
  • All Pages, not with RH: Selected section will appear on all the pages, but not on page having the Report Header.
  • All Pages, not with RF: Selected section will appear on all the pages, but not on page having the Report Footer.
  • All Pages, not with RH, not with RF: Selected section will appear on all the pages, but not on page having the Report Header and not on the page having Report Footer.

Prompt

This property defines the string that should be used as prompt when the selected field is an editable field.

PrintWidth

Report controls are placed on canvas. This property sets width of the canvas.

ReferencedReportName

Name of the report that is referenced the sub-report. Value auto-appears based on value stored in Source property of the sub-report control.

ScriptLanguage

Application supports only one language - Jscript.

ShowParameterUI

This property defines if parameter dialog box will appear or not.

  • True: Query parameter dialog box will appear.
  • False: Query parameter dialog box will not appear.

Source

A deployed report that is selected as a sub-report.

SortOrder

This property controls the sort order of group field (when report has groups).

  • ASC: Ascending order.
  • DESC: Descending order.

SubReportType

To select the sub-report type.

  • Embedded: Stored as part of this report.
  • Referenced: To be referred to as an already deployed report.

SummaryCondition

To get summary based on specified condition.

SummaryDistinctField

This property will be available in Properties list when a control is selected from the details section. It is used only when the ‘SummaryFunc’ value is one of the ‘distinct summary functions’. The ‘SummaryDistinctField’ property sets or returns the name of the field used in a distinct summary function. The summary function will process the ‘DataField’ values based on the distinct value of this field. Note: When using the summary functions with a field, the ‘CanGrow’ and ‘CanShrink’ properties are disabled for the same field.

Text

You can utilize this option through the Script Editor. It defines the text string to be displayed in the field.

To perform the same using the Script Editor, type the following code:

Object: Detail
Event: OnFormat
Code:
function OnFormat()
{
if ( rpt.Sections("Detail").Controls("txtItem").text == "" )
{ rpt.Sections("Detail").Controls("txtItem").text = "None"; }
}

TOCField

This property defines if selected field should appear as a TOC entry or not.

Visible

This property defines if the control would appear at run time or not.

  • True: The control would appear at run time.
  • False: The control would not appear at run time.

Watermark

This property will appear in the property pane when you select the ‘Main Report’ option from the Report Explorer window. It adds a specified image to the report's background. The ‘watermark’ image can be positioned, sized, aligned and placed on specified pages by using the other watermark properties. When you select this property in the property pane, Open dialog box will appear for you to choose and select the file to be used as watermark.

Note: .jpg and .gif image type can be used with Watermark. After setting an image, if you do not want the image to appear, change the value of property WaterMarkPrintOnPages to zero.

WatermarkAlignment

This property will appear in the properties list when you select the ‘Main Report’ option from the Report Explorer window. It defines the watermark's general vertical and horizontal positions when it is added to the ‘Canvas’.

  • 0-ddPATopLeft: To align the watermark to the top left margin of the page.
  • 1-ddPATopRight: To align the watermark to the top right margin of the page.
  • 2-ddPACenter: To align the watermark in the center of the page.
  • 3-ddPABottomLeft: To align the watermark to the bottom left margin of the page.
  • 4-ddPABottomRight: To align the watermark to the bottom right margin of the page.

WatermarkPrintOnPages

This property will appear in the properties pane when you select the ‘Main Report’ option from the Report Explorer window. Specify the number of pages on which watermark should be printed.

WordWrap

This option will be available in Properties list if you select a control from the layout pane. It defines whether or not the label's caption will wrap.

  • True: To wordwrap the text. To select this option, Multiline property must also be set to ‘True’.
  • False: If the value is longer that the width of the control, it will be clipped.

To perform the same using the Script Editor, type the following code:

Object: Detail
Event: OnFormat
Code:
function OnFormat()
{
rpt.sections("Detail").controls("txtItem").wordWrap = false;
}

ZeroValue

This property is available for field controls. Set the value that should appear on the report in case value for the field control is zero.

See Also

  • Appearance
  • Behavior
  • CSV Output format
  • Data
  • Font
  • Image Rendering
  • Position
  • Text
  • XLS Output


Appearance related properties

Alignment

This property will be available in property pane if you select a field control from the layout window. It determines alignment of the value (left, right or center) within the control.

  • 0-ddTXLeft: To left-align the value within control. This is default alignment for character type fields.
  • 1-ddTXRight: To right-align the value within control. This is default alignment for number type fields.
  • 2-ddTXCenter: To center-align the text. In this type of alignment, text will be exactly in the middle within the control.

AlternateBackcolor

User of alternate colors enhances readability.

  • Crosstab: Color to be used for the next row.
  • Chart: Color to be used for plot area between two scale markers.

AlternateForecolor

User of alternate colors enhances readability.

  • Crosstab: Color to be used for the text used in the next row.

AutoFormat

Property available for chart. Set it true to automatically apply following formatting attributes:

  • Multicolor
  • Label Angle (Axis > Style)
  • Chart Margins (Settings)
  • Angle (Series > Point labels)

BackColor

This property is used to set background color of a control or a section.

Note: BackColor property will be effective only when BackStyle property is set to Normal (1-ddBKNormal) .

BackStyle

This property will be available in property pane if you select a field control or a section from the layout pane. Its value determines if background color will be applicable or not.

  • 0-ddBKTransparent: To show the background content. This will not hide the background content by applying the BackColor.
  • 1-ddBKNormal: To apply BackColor. This will hide background color.

You can also perform the same through the Script Editor as shown in the example below:

Object: Detail
Event: OnFormat
Code:
function OnFormat()
{
if (parseInt(rpt.section("Details").controls("txtSales").dataVa lue) >
1000 );
{ rpt.section("Details").controls("txtSales").backStyle = 1; // Back Style
Normal }
else { rpt.section("Details").controls("txtSales").backStyle = 0; // BackStyle
Transparent }
}

Border

It defines the border surrounding the labels and fields. It can be changed through the shortcut menu or using the script editor.

An example for the same is given below to set the border to a single blue border.

Object: Detail
Event: OnBeforePrint
Code:
function OnBeforePrint()
{ rpt.Sections("Detail").Controls("txtSales").borderTopStyle=1 ;
rpt.Sections("Detail").Controls("txtSales").BorderTopColor=" 0";
rpt.Sections("Detail").Controls("txtSales").borderLeftStyle= 1;
rpt.Sections("Detail").Controls("txtSales").BorderLeftColor= "0";
rpt.Sections("Detail").Controls("txtSales").BorderRightStyle ="1";
rpt.Sections("Detail").Controls("txtSales").BorderRightColor ="0";
rpt.Sections("Detail").Controls("txtSales").borderBottomStyle=1;
rpt.Sections("Detail").Controls("txtSales").BorderBottomColo r="0";
}

Bordercolor

Border color of the selected control.

BorderStyle

Line style for the selected control.

BorderWeight

Thickness of the border.

Caption

This property is applicable for label controls. Its value is displayed for the selected label at report execution time.

CellCaps

This property is available for cross-tab control.

  • True: To show cell captions at run time.
  • False: To hide cell captions at run time.

Chart3D

This property is available for chart control.

  • True: To get 3D chart (chart having depth element).
  • False: To get 2D chart.

CrossTabTitle

Text that will appear in extreme top-left cell of the cross-tab component.

CloseBorder

This property is available for frame control.

  • True: Renders bottom border line even if frame spans to next page.
  • False: Does not render bottom line if frame spans to next page.

ForeColor

This will set the foreground (text color) of the selected control. When you choose this option from the properties window, a color palette will open up to choose colors from.

You can also change the forecolor (text color) of a control by writing a script. The following example will display a red colored ‘confidential’ text at the top-left corner of each page.

Object: Detail
Event: OnFormat
Code:
function OnFormat()
{
rpt.Sections("Detail").Controls("txtSales").foreColor = 25545255;
}

Gallery

This property is used to select the type of Chart you want to create.

Grid

This property is used to set or remove the appearance of grid lines for the selected axis.

Linecolor

This property will be available in property pane when a Line control or Shape control is selected. It defines the color of the Line used to draw the line or shape. You can select a color from the available options or can create color as per the need.

LineStyle

This property will be available in property pane when a Line control or Shape control is selected. Its value determines the style of line that will be applied to the selected control.

  • 0: Transparent: This will display a transparent line.
  • 1: Solid
  • 2: Dash
  • 3: Dot
  • 4: Dash-Dot
  • 5: Dash-Dot-Dot

LineWeight

This property will be available in the property pane when Line control or Shape control is selected. It defines the thickness of line. A value of zero will not draw line. The line will become thicker with higher values. Unit of measure of thickness of line is pixels. You can select a color from the available options or can create color as per the need.

MultiLine

This will appear in the properties list if you select a control from layout pane. It determines whether the contents of the field should wrap across multiple lines.

  • True: The field text is NOT limited to a single line.
  • False: The field text is limited to a single line regardless of the height or ‘CanGrow’ property.

To perform the same using the Script Editor, type the following code:

rpt.sections("Detail").controls("txtName").multiLine =
true;
rpt.sections("Detail").controls("txtName").canGrow = true;
rpt.sections("Detail").controls("txtName").canShrink = false;

MultipleColors

This property is available for chart control.

  • True: To use different colors to plot different series.
  • False: To plot all the series with the same color.

OutputFormat

String having masking character pattern to be applied for selected control.

Picture

This property will be available when a picture control is placed on the report (and is selected). This property sets the picture that will be placed on the report at run time.

The image types that you can use are: bmp, ico, jpg, cur, gif and wmf.

If the image you have selected is larger than the placeholder the image will be auto-cropped equally from all the sides. If it is smaller than the placeholder, application will add equal amount of empty space on all the sides around the image.

PictureAlignment

This option will be available if you select a picture from the layout pane.

  • 0-Top: Left To align the picture to the top left corner of the image control area.
  • 1-Top Right: To align the picture to the top right corner of the image control area.
  • 2-Center: To align the picture in the center of the image control area.
  • 3-Bottom Left To align the picture to the bottom left corner of the image control area.
  • 4-Bottom Right: To align the picture to the bottom right corner of the image control area.

PointLabels

This property is available with chart control.

  • True: To display the values of each data point for all series in chart.
  • False: To hide the point values.

RGB2DBK

Use this property to set background color and 2D effect on plot area of chart.

RGB3DBK

Use this property to set background color of plot area of the chart when chart is a 3D chart.

RGBBK

This property is used to set background color of Chart.

Scheme

This property is used to apply the scheme on the cross-tab. This contains predefined format settings for the cross-tab reports.

Shape

To set type of the shape control.

ShowLegend

This property controls visibility of legend on chart.

  • True: To display legends on chart.
  • False: To hide legends from chart.

SplitPie

This property controls how pie of pie chart will be displayed. On dialog box, select the checkbox to get Split view.

Style

This is combination of Alignment, BackColor, ForeColor, Font properties. All these properties set style for a control.

Theme

Use this property to apply pre-configured color combination on the chart.

View3DDepth

Use this property to set depth in case of a 3D chart.

VerticalAlignment

This property is used to set vertical alignment of value of selected control. It can be Top, middle or bottom.

See Also

  • Behavior
  • CSV Output format
  • Data
  • Font
  • Image Rendering


Behavior related properties

CanGrow

This option will appear in the properties pane if you select a field control from the layout pane. This property determines whether Intellicus Studio should increase the height of the field based on its value size (length).

  • True: To increase height of the control and shift all controls below it to adjust with the increase in height.
  • False: To clip the text to fit within the control's predefined height.

Important: The increase in height might cause the section height to increase. The section's ‘CanGrow’ property should be set to ‘True’ to avoid clipping the section.

To perform the same using the Script Editor, type the following code:

rpt.sections("Detail").controls("txtName").multiLine =
true;
rpt.sections("Detail").controls("txtName").canGrow = true;
rpt.sections("Detail").controls("txtName").canShrink = false;

CanShrink

This property will be available in the properties list when you select a field control. It determines whether Intellicus Studio should decrease the height of the control based on the value of the field.

  • True: To decrease the height of the field to exactly fit the contents and shift the control below it upward to adjust with the decrease in height.
  • False: The field will take the exact area defined by its preset coordinates.

ColumnLayout

This property will appear in the properties list if the group header/ footer section is selected. It determines whether a group header section should use the same column layout as of its detail section.

  • True: The number of columns in a detail section will be reflected in the associated group headers and footers.

  • False: The number of columns in a detail section will not be reflected in the associated group headers and footers.

Note: This property applies to group header and group footer sections only.

To perform the same using the Script Editor, type the following code:

rpt.sections("GHLocation").columnLayout= false

ColumnCount

This option will be available in the properties list only when the details section is selected. It defines the number of columns in the report. This property can be used to print labels, or phonebook style listings. The width of each column equals the ‘PrintWidth’ of the report divided by the number of columns.

You can use the ‘ColumnLayout’ property to force associated group headers and footers to follow the same column format as their detail section.

To perform the same using the Script Editor, type the following code:

rpt.sections("Detail").columnCount = 3 ;
rpt.sections("Detail").columnDirection = 1;

ColumnDirection

This property will be available if you click on a section in the layout pane. This property determines how Intellicus Studio should print the detail section in a multi-column report.

  • 0-DownAcross: This will print first column from top to down and repeat the same for next column to its right. (Column-wise printing).
  • 1-AcrossDown: This will print the first row spanning across all columns followed by next row. (Row-wise printing).

When DownAcross is selected, the printing will go to the next column after the column on the left is completely printed. You can also define the same through Script Editor as shown in the example below.

Object: Detail
Event: OnFormat
Code:
function OnFormat() { rpt.Sections("Detail").columnCount = 3;
rpt.Sections("Detail").columnDirection = 1;}

ColumnSpacing

This option will be available if you select the detail section only. It defines the space between columns (in twips) in a multicolumn report.

To perform the same using the Script Editor, type the following code:

rpt.sections("Detail").columnSpacing= 0.5 * 1440

Enabled

Applicable for Page Break control.

  • True: To enable page break effect of the Page Break control.
  • False: To disable page break effect of the Page Break control.

GrpKeeptogether

This property will be available if you select the group section (header or footer). This option applies to group header sections and determines whether group header and group footer sections will print on the same page or not.

  • 0-None: To let the group split across pages.
  • 1-FirstDetail: To print the complete block on the same page without any page-breaks. When a complete block does not fit on a single page, it will be split across two or more pages.
  • 2-All: To let the group header, detail, and group footer get printed on the same page.

You can achieve the same through the Script Editor. For example,

rpt.sections("GHCategory").grpKeepTogether = true ;

Hyperlink

This property will appear in the properties pane when you select a control from the layout pane. It defines a ‘hyperlink’ for a field; once this ‘hyperlink’ is set; you can follow the specified link by clicking it at run-time.

Note: The hyperlink can link any properly formatted HTML URL.

To perform the same using the Script Editor, type the following code:

Object: Detail
Event: OnFormat
Code:
function OnFormat()
{
rpt.Sections("Detail").Controls("txtLink").hyperLink = "www.<yourcompany>.com";
rpt.Sections("Detail").Controls("txtLink").text = "Click to see your web site";
}

KeepTogether

This option will be available in the properties pane if you select any section (except page header/ footer) from the layout pane. It determines whether a whole section should print on the same page.

  • True: The section will print on the same page without any page breaks.
  • False: The section will split across two or more pages.

To perform the same using the Script Editor, type the following code:

rpt.sections ("Detail").keepTogether = false;

NewColumn

This property will appear in properties list if detail section is selected from layout pane. This property determines whether Intellicus Studio should insert a column-break before and/or after printing the section.

Note: This property does not apply to report header, report footer, page header, and page footer sections.

  • 0-None: No page-break before the section.
  • 1-Before: Start printing the section on a new page.
  • 2-After: Start a new page after printing the section.
  • 3-Before and After: Page-break before and after a section. Start printing the section on a new page and start a new page after printing it.

To perform the same using the Script Editor, type the following code:

Object: Detail
Event: OnFormat
Code:

Section : Report Level
Event OnDataInitialize
function OnDataInitialize() { rpt.fields.add("rNumber");
rpt.fields("rNumber").value = 0 ; }

Section : Detail event " OnFormat()
function onFormat()
{
rpt.fields("rNumber").value =
parseInt(rpt.fields("rNumber").value) + 1 ;
if ( rpt.fields("rNumber").value ==
6)
{ rpt.section("Detail").newColumn = 2 rpt.fields("rNumber").value = 0 ; }
else
{ rpt.section("Detail").newColumn = 0 ; }
}

NewPage

This property will appear on properties list if you the details section from the layout pane. It determines whether Intellicus Studio should insert a page-break before and/ or after printing the section.

Note: This property does not apply to page header or page footer sections.

  • 0-None: No page-break before the section.
  • 1-Before: Start printing the section on a new page.
  • 2-After: Start a new page after printing the section.
  • 3-Before and After: Start printing the section on a new page and start a new page after printing it.

To perform the same using the Script Editor, type the following code:

Object:
Report
Event: OnDataInitialize
function OnDataInitialize() {
rpt.Fields.add("Pre_Val"); rpt.Fields("Pre_Val").value=0; }
Object: Detail
Event : OnFormat
function OnFormat()
{ rpt.Fields("Pre_Val").value =
parseInt(rpt.Fields("Pre_Val").value) + 1 ;
if ( parseInt(rpt.Fields("Pre_Val").value) == 6 )
{ rpt.Sections("Detail").newPage =
2; rpt.Fields("Pre_Val").value = 0 ; }
else { rpt.Sections("Detail").newPage = 0
; }
}

Repeat

This property is available for cross-tab control.

  • True: To repeat row headers on each page.
  • False: To have row headers only on the first page of cross-tab.

Stacked

Select type of the bar chart from available options.

See Also

  • Appearance
  • CSV Output format
  • Data


Position related properties

Height

This option will be available in the Properties list if you select any section from the layout pane. It defines the section's height in twips.

Important: A section's height can only be changed using the ‘Format’ event, the ‘ReportStart’ event, or before the report is run. Changing the height will not automatically reposition the controls inside the section.

To perform the same using the Script Editor, type the following code:

rpt.sections("Detail").height = 2*1440

Left

This property will be available in property pane when a field control is selected. It sets the distance of left boundary of the control from the left edge of the report page. The unit of measure is pixels.

LeftGap

This property is used to set distance between left chart border and plot area.

RightGap

This property is used to set distance between right chart border and plot area.

Top

This property is available for a field control. This sets the distance of the control from the top edge of the report page. The unit of measure is pixels.

TopGap

This property is used to set distance between right chart border and plot area.

Width

This property is available for a field control. This sets the width (left to right) of the control. The unit of measure is pixels.

x1

Defines x coordinate of starting point of line.

x2

Defines x coordinate of ending point of line.

y1

Defines y coordinate of starting point of line.

y2

Defines y coordinate of starting point of line.

See Also

  • Appearance
  • Behavior
  • CSV Output format
  • Data


XML output related properties

XMLCdata

Set value for this property if this report will be exported to XML format. Value set in this property decides if the control should be included in XML output or not. Leave this as TRUE if data for this field may contain character(s) that violets XML Specifications. When it is set to TRUE, data is placed in CDATA.

Note: This property can be used only if XMLType is ELEMENT.

XMLTagName

Set value for this property if this report will be exported to XML format. Use this property to specify the tag-name for selected control. This tag name will be used when this report is exported in XML. If by default the property is kept blank. In this case, field name is used as tag name.

XMLType

Set value for this property if this report will be exported to XML format. Value set in this property decides if the control should be included in XML output or not.

  • EXCLUDE: To exclude this control from XML Output.
  • ELEMENT: To include this control as an element of XML.
  • ATTRIBUTE: To include this control as an attribute of XML.

By default the property does not have any value. In this case, the value is considered as element.

See Also

  • Appearance
  • Behavior
  • CSV Output format
  • Data


Font related properties

Font

This option will be available in the Properties list if you select a label or a field control from the layout pane. This property allows you to set font name, size, styles, and effects. When you select this option from the Properties list, Font dialog box will appear to select various options for the font. You can also change the font settings for a control at runtime, depending on conditions applied on the same.

The following examples sets the sales figure above a certain value to a bold, underline format.

Object: Detail Event: OnFormat
Code:
function OnFormat()
{
if
(parseInt(rpt.sections("Details").controls("txtSales").dataValue) > 10000)
{
rpt.sections("Details").controls("txtSales").bold = true;
rpt.sections("Details").controls("txtSales").font.underLine = true;
}
else
{
rpt.sections("Details").controls("txtSales").bold = false;
rpt.sections("Details").controls("txtSales").font.underLine = false;
}
}

See Also

  • Appearance
  • Behavior
  • CSV Output format
  • Data


Text related properties

Edit

Applicable for an RTF control.

  • True: To enable edit feature on the field during preview.
  • False: To disable edit feature on the field during preview.

MaxLength

Specify the maximum number of characters that can be inserted in selected rich text control.

MultiLine

This will appear in the properties list if you select a control from layout pane. It determines whether the contents of the field should wrap across multiple lines.

  • True: The field text is NOT limited to a single line.
  • False: The field text is limited to a single line regardless of the height or CanGrow property.

To perform the same using the Script Editor, type the following code:

rpt.sections("Detail").controls("txtName").multiLine = true;
rpt.sections("Detail").controls("txtName").canGrow = true;
rpt.sections("Detail").controls("txtName").canShrink = false;

See Also

  • Appearance
  • Behavior
  • CSV Output format
  • Data


Data related properties

ConnectionName

This property is for cross-tab control. It sets the connection name to be used to fetch data for the selected cross-tab control.

ConnectionType

This property is for cross-tab control. It defines database connection type:

  • Default: Use default connection of report server.

  • Parent: Use connection set in the main report.

  • Named: Use the connection set in RuntimeConnectionName property. This property will get its value at run time.

ReportName

This property is for sub-report control. It defines name of the linked report object.

RuntimeConnectionName

This property is for cross-tab control. It defines database connection name that user specifies at run time.

SummaryFunc

This option will be available if you select a field control from the layout pane. It sets the type of the summary function used to process the selected field’s values. You can use this function to create sub totals, grand totals, and other summary values.

  • 0-Sum: This will calculate the total of all values within the specified summary region (group, page or report).
  • 1-Avg: This will calculate the average of all values within the specified summary region.
  • 2-Count: This will calculate the count of all values within the specified summary region.
  • 3-Min: This will calculate the minimum of all values within the specified summary region.
  • 4-Max: This will calculate the maximum of all values within the specified summary region.
  • 5-Variance: This will calculate the variance of all values within the specified summary region.
  • 6-PopVariance: This will calculate the population variance of all values within the specified summary region.
  • 7-StdDeviation: This will calculate the standard deviation of all values within the specified summary region.
  • 8-PopStdDeviation: This will calculate the population standard deviation of all values within the specified summary region.
  • 9-DistSum: This will calculate the total based on the distinct values of another field within the specified summary region.
  • 10-DistAvg: This will calculate the average based on the distinct values of another field within the specified summary region.
  • 11-DistCount: This will calculate the distinct count based on the distinct values of another field within the specified summary region.
  • 12-DistVariance: This will calculate the variance based on the distinct values of another field within the specified summary region.
  • 13-DistPopVariance: This will calculate the population distinct variance based on the distinct values of another field within the specified summary region.
  • 14-DistStdVariance: This will calculate the standard deviation based on the distinct values of another field within the specified summary region.
  • 15- DistinctPopStdVariance: This will calculate the population standard deviation based on the distinct values of another field within the specified summary region.

SummaryGroup

This option will be available if you select a field control from the layout pane. It defines the name of the group header section that will reset the summarized field value.

Note: When using the summary functions with a field, the ‘CanGrow’ and ‘CanShrink’ properties are disabled for the field.

SummaryRunning

This option will be available if you select a field control from the layout pane. It determines whether the summarization will be accumulated or reset for each level (detail-, group- or page).

Setting this property as ‘1-RunGroup’ or ‘2-All’ will make Intellicus Studio print a running summary of the field at the group or report level.

  • 0 - None: To calculate a running summary.
  • 1 - RunGroup: This will calculate a running summary. Each value is the sum of the current value and all preceding values (within a same group).
  • 2-All: This will calculate a running summary for all values. Note: When using the summary functions with a field, the ‘CanGrow’ and ‘CanShrink’ properties are disabled for the field.

SummaryType

This property will appear in the property pane if a field control is selected from the layout pane. It specifies the level at which the summarization can be used on the fields. The following summary types are available:

  • Sub total: Group level, for each group.
  • Grand total: Report level, for all records in the report.
  • Page total: Page level, for each page.
  • Page count: Total number of pages printed.

If the summarized field is placed ahead of its summary level (Placing a page total in the page header or a report grand total in the report header), the containing section and the following sections will not be printed until the summary value is resolved / calculated. While using the summary functions on a field, the CanGrow and CanShrink properties are disabled for the selected field.

  • 0-None: No summarization will take place.
  • 1-GrandTotal: This will specify a report level summary, and evaluate the summary function for all records in the report.
  • 2-PageTotal: This will specify a page level summary, and evaluate the summary function for all records on each page.
  • 3-SubTotal: This will specify a group level summary, and evaluate the summary function for all records in each group level.
  • 4-PageCount: This will specify a Page Count field.

Tag

Sets or returns a user defined value associated with the field object.

Value

Sets or returns the current value of the field object. To perform the same using the Script Editor, type the following code:

function OnFetchData(eof)
{
rpt.Fields.("Amount").value = parseInt(rpt.Fields("Qty").value *
rpt.Fields("Price").value);
}

See Also

  • Appearance
  • Behavior
  • CSV Output format


CSV Output related properties

IncludeInCSV

This property is available at control level and group level. Set value for this property when the report is going to be exported in CSV. Value specified for this property will decide if the selected control will be added on CSV output or not.

  • Never: The selected field will not be included in CSV output.
  • Once: Selected item will appear only once in the report. For example, page headers and page footers.
  • Repetitive: Selected items will appear once for each occurrence in the report. For example, controls in the detail section.
  • Blank: Report server will assume default values. Repetitive for detail section, Once for page header, Never for Report Header, Report Footer, Page Footer, Group Header and Group Footer.

See Also

  • Appearance
  • Behavior
  • Data


Image Rendering related properties

ImagePath

Value of this property decides the path from where the image should be picked up.

Important: This is the path to the image file on computer where Intellicus report server is running.

ImageSourceType

Value of this property decides the source for selected image.

  • Path: Select this if image is located on local, or a network path that can be accessed from the machine where Intellicus Report Server is running.
  • URL: Select this if image is to be fetched from a web location.
  • Binary Data: Select this to pick up the image at run time from a field in database, or embed the image in report (IRL) by picking it up from a path.

See Also

  • Appearance
  • Behavior
  • CSV Output format
  • Data


Property Values

The Property window contains property name and property values. The values in the Property window would change, depending on the field control that you select from the Layout window .

Property details are organized by their groups. To arrange properties by group, click the left most icon on top of the property pane.

See Also

  • Appearance
  • Behavior
  • CSV Output format
  • Data


Properties in Studio

First topic in project 'Properties Description'